Помогите установить

Общие обсуждения публичной версии проекта "Сверхновая"
Support forum for public version

Модератор: Gorlum

Правила форума
Внимание! Этот форум - только для обсуждения вопросов и проблем на сторонних серверах, использующих движок Сверхновой!

Для обсуждения оригинальных серверов СН существуют соответствующие форумы: для багрепортов, для обсуждение движка на офф-серверах.

Общие багрепорты и проблемы на публичных серверах обсуждаются в соответствующем форуме.

Для обсуждения работа модулей и багрепротов по их работе существует свой форум
Igor628
Рядовой
Сообщения: 6
Зарегистрирован: 01 фев 2015, 12:55

Помогите установить

Сообщение Igor628 » 01 фев 2015, 13:02

Все вроде делал по инструкции, ошибка вот такая:
Parse error: syntax error, unexpected T_FUNCTION, expecting ')' in /home/fantomas/public_html/SuperNova/includes/init.php on line 21
что это может быть? заранее спасибо.

Igor628
Рядовой
Сообщения: 6
Зарегистрирован: 01 фев 2015, 12:55

Re: Помогите установить

Сообщение Igor628 » 03 фев 2015, 00:01

Может надо установить более раннюю версию, а потом обновить до последней?
Устанавливаю на домен 2-го уровня, типа supernova.domen.com. Может в этом проблема? Хотя сюда же ставлю другие подобные игры - все работает... Но хочу эту версию! Подскажите, что не так? Или тут уже никого нет?

Gorlum
Император Вселенной
Сообщения: 7315
Зарегистрирован: 13 июн 2009, 15:06
Контактная информация:

Re: Помогите установить

Сообщение Gorlum » 03 фев 2015, 00:28

Уровень домена - похрен. Можно ставить хоть
domain.com/folder/

Проверь соответствия требованиям: версия PHP, версия MySQL, настройки PHP, версия xCache, настройки xCache

Попробуй перекачать 38-й релиз с SourceForge и поставить поверх уже 39й. 39й пока в статусе BETA - т.е. там несогласованные SQL-файлы. Хотя чисто теоретически - это не должно представлять проблем, движок сам должен заапгрейдить неправильные таблицы

Обратись к файлу
docs/install.txt
Прочитай его ПОЛНОСТЬЮ. Там есть список минимальных требований (см.выше).
Там есть секция "Если возникли проблемы с обновлением или инсталляцией", в которой приведен простой алгоритм диагностики неисправностей. Выяви, на каком этапе у тебя проблемы для помощи

На крайний случай - есть платная диагностика и помощь
ВНИМАНИЕ! Администрация в личную переписку не вступает, рукописи не возвращает и не рецензирует!
* Если у меня слишком хорошее настроение - я хожу почитать чат *

Igor628
Рядовой
Сообщения: 6
Зарегистрирован: 01 фев 2015, 12:55

Re: Помогите установить

Сообщение Igor628 » 04 фев 2015, 03:31

Поставил 38, автоматом запустилось обновление.
После выдает вот такое сообщение:
Internal error! Auotupdater detects DB version greater then can be handled!
Possible you have out-of-date SuperNova version
Pleas upgrade your server from GIT repository.
Скачиваю 39, ставлю сверху, выдает тоже, что и раньше:
Parse error: syntax error, unexpected T_FUNCTION, expecting ')' in /home/fantomas/public_html/moons/includes/init.php on line 22
Может что-то не то с минимальными требованиями или с настройками БД или пхп... буду искать...

Gorlum
Император Вселенной
Сообщения: 7315
Зарегистрирован: 13 июн 2009, 15:06
Контактная информация:

Re: Помогите установить

Сообщение Gorlum » 04 фев 2015, 07:04

Igor628 писал(а):Поставил 38, автоматом запустилось обновление.
После выдает вот такое сообщение:
Internal error! Auotupdater detects DB version greater then can be handled!
Possible you have out-of-date SuperNova version
Pleas upgrade your server from GIT repository.
Скачиваю 39, ставлю сверху, выдает тоже, что и раньше:
Parse error: syntax error, unexpected T_FUNCTION, expecting ')' in /home/fantomas/public_html/moons/includes/init.php on line 22
Может что-то не то с минимальными требованиями или с настройками БД или пхп... буду искать...
Старая версия PHP - апгрейдь PHP хотя бы до 5.3.9
ВНИМАНИЕ! Администрация в личную переписку не вступает, рукописи не возвращает и не рецензирует!
* Если у меня слишком хорошее настроение - я хожу почитать чат *

Igor628
Рядовой
Сообщения: 6
Зарегистрирован: 01 фев 2015, 12:55

Re: Помогите установить

Сообщение Igor628 » 04 фев 2015, 15:11

Может быть... Стоит 5.2.17. Попробую обновить, отпишусь потом. Главное, чтоб изменение версии БД не повлияло на мои другие БД, которые сейчас нормально работают... Короче говоря, я о совместимости...

Igor628
Рядовой
Сообщения: 6
Зарегистрирован: 01 фев 2015, 12:55

Re: Помогите установить

Сообщение Igor628 » 07 фев 2015, 20:19

поменял версию PHP на PHP 5.5 вроде запустилось... но выдает
Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/u225930560/public_html/includes/db.php on line 115

поменял на PHP 5.4 - надпись исчезла, прошло обновление, дальше открывается синяя картинка с текстом:
SuperNova
Игра еще не сконфигурирована
Project "SuperNova.WS" Release 38 V39b4.2 © 2009-2015 Gorlum
Inspired by XNova RageRepack v226
Benchmark 0.059911012649536s, memory: 3,058,848 (эти данные при обновлении страницы меняются...)

а как войти в админку, чтоб все сконфигурировать то?
или опять поставить старую версию, чтоб она сама обновилась?
или конфигурировать все в ручную?
или что-то еще не так?

Igor628
Рядовой
Сообщения: 6
Зарегистрирован: 01 фев 2015, 12:55

Re: Помогите установить

Сообщение Igor628 » 07 фев 2015, 21:57

попробовал залить предыдущюю версию выдало вот
SuperNova
SuperNova is in maintenance mode! Please return later!
Project "SuperNova.WS" Release 38 V38d0 © 2009-2014 Gorlum
Based on XNova RageRepack v226
Это всмысле происходит обновление? Просто зайти позже? Или это все, приехали?

Gorlum
Император Вселенной
Сообщения: 7315
Зарегистрирован: 13 июн 2009, 15:06
Контактная информация:

Re: Помогите установить

Сообщение Gorlum » 08 фев 2015, 06:45

Или прочитать документацию? Или я зря потратил сотни часов на её написание?
ВНИМАНИЕ! Администрация в личную переписку не вступает, рукописи не возвращает и не рецензирует!
* Если у меня слишком хорошее настроение - я хожу почитать чат *

arheonis
Рядовой
Сообщения: 6
Зарегистрирован: 01 мар 2015, 15:04

столкнулся с проблемой помогите:

Сообщение arheonis » 01 мар 2015, 20:06

действовал точно по схеме

ВЕРСИЯ APACHEApache/2.4.10
РНР ВЕРСИЯ 5.5
ВЕРСИЯ MYSQL 5.1.61

ошибка:
Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/u480752848/public_html/supernova/includes/db.php on line 115

SuperNova
Игра еще не сконфигурирована
Project "SuperNova.WS" Release 38 V39b6.23 © 2009-2015 Gorlum
Inspired by XNova RageRepack v226

от 115 строки до 121 последовательно вот что идет:

Код: Выделить всё

  $link = mysql_connect($dbsettings['server'], $dbsettings['user'], $dbsettings['pass']) or $debug->error(mysql_error(),'DB Error - cannot connect to server');

  mysql_query("/*!40101 SET NAMES 'utf8' */") or die('Error: ' . mysql_error());
  mysql_select_db($dbsettings['name']) or $debug->error(mysql_error(), 'DB error - cannot find DB on server');
  // mysql_query('SET SESSION TRANSACTION ISOLATION LEVEL ' . DB_MYSQL_TRANSACTION_REPEATABLE_READ . ';') or die('Error: ' . mysql_error());
  mysql_query('SET SESSION TRANSACTION ISOLATION LEVEL ' . DB_MYSQL_TRANSACTION_REPEATABLE_READ . ';') or die('Error: ' . mysql_error());
  unset($dbsettings);
помогите найти проблему очень буду признателен испробовал всё что писали в возможных решениях

что-то ему в MySQL не нравится, но что именно? может какие-то элементы таблицы добавить? дайте тогда код для добавления через PHP Admin

Ответить

Вернуться в «[ru/en] Публичная версия/Public releases»